Browsed by
分類:JavaScript

[JS] When upgrade Webpack from v3 to v4…

[JS] When upgrade Webpack from v3 to v4…

When I upgraded Webpack from v3 to v4, I got a bunch of errors. I already get used to encountering the errors when I upgrade the Webpack, sigh027

The first 2 errors I encountered were CommonsChunkPlugin and UglifyJsPlugin.

Error: webpack.optimize.CommonsChunkPlugin has been removed, please use config.optimization.splitChunks instead.
...
Error: webpack.optimize.UglifyJsPlugin has been removed, please use config.optimization.minimize instead.

Read More Read More